Allied Telesis Cấu hình OSPF trên Switch Allied Telesis

HanaLink

Junior – IT Sơ cấp
Mar 11, 2022
123
15
18
25
Ho Chi Minh City
Trong bài viết này mình sẽ hướng dẫn cách cấu hình OSPF trên Switch Allied Telesis.

Các dòng thiết bị có hỗ trợ cấu hình OSPF yêu cầu chạy phần mềm AlliedWare Plus OS phiên bản 5.2.1 trở lên:
  • SwitchBlade x8100 Series Switches (CFC400 and CFC960)
  • SwitchBlade x908 Switch
  • x510 Series Switches
  • x600 Series Switches
  • x610 Series Switches
  • x900-12 Series Switches
  • x900-24 Series Switches
Mô hình:
1710235265222.png


Bước 1: Truy cập vào mode cấu hình OSPF:
Code:
 sbx908-x600-awplus#configure terminal
sbx908-x600-awplus(config)#router ospf 1
sbx908-x600-awplus(config-router)#
Trong đó, thông số OSPF ID (1) dùng để định danh tiến trình OSPF local của thiết bị dùng trong trường hợp thiết bị có thể tham gia nhiều tiến trình OSPF cho các vùng khác nhau, nghĩa là ID này chỉ được trao đổi bên trong thiết bị và không ảnh hưởng đến các thiết bị khác. Giá trị ID sẽ từ 1 đến 255.

Bước 2: Cấu hình thông tin Network
Code:
 sbx908-x600-awplus(config-router)#network 192.168.1.0 0.0.0.255 area 0
Trong đó:
  • Giá trị Wildcard mask (0.0.0.255) tương ứng với dãy địa chỉ trên thiết bị là 192.168.1.2/24
  • Giá trị Area ID (0) xác định thông số của phân vùng Area OSPF của lớp mạng ta muốn cấu hình, có thể cấu hình dưới dạng số nguyên thập phân hoặc dạng X.X.X.X
  • Trường hợp nếu muốn cấu hình OSPF cho tất cả các lớp mạng của thiết bị ta có thể dùng lệnh
Code:
sbx908-x600-awplus(config-router)#network 0.0.0.0 255.255.255.255 area x

Bước 3: Để cấu hình Reditributing route ta dùng lệnh:
Code:
sbx908-x600-awplus(config)#router ospf 1
 sbx908-x600-awplus(config-router)#redistribute connected
 sbx908-x600-awplus(config-router)#network 192.168.1.0 0.0.0.255 area 0
Reditributing OSPF cho phép các route đã học qua các giao thức/phương thức khác được quảng bá vào OSPF ví dụ như BGP, Connected, RIP và Static route. Như mô hình trên ta có các lớp mạng 10.0.0.0/8, 20.0.0.0/8 và 30.0.0.0/8 vì vậy khi show thông tin ta sẽ thấy:
Code:
sbx908-x600-awplus#show ip route
O E2 10.0.0.0/8 [110/20] via 192.168.1.1, vlan24, 00:00:08
O E2 20.0.0.0/8 [110/20] via 192.168.1.1, vlan24, 00:00:08
O E2 30.0.0.0/8 [110/20] via 192.168.1.1, vlan24, 00:00:08
B    40.0.0.0/8 [20/0] via 172.16.0.2, vlan5, 00:16:47   
C    172.16.0.0/16 is directly connected, vlan5
C    192.168.1.0/24 is directly connected, vlan24
Trong đó:
  • Các route được hiển thị dưới dạng "O E2" có nghĩa đây là các tuyến loại 2 bên ngoài OSPF do cấu hình redistributing OSPF.
1710313105321.png

  • Thông số Metric 20 (trong thông tin [110/20]) là giá trị metric mặc định của redistribute route, ngoại trừ redistribute BGP sẽ cho metric là 1. Ta vẫn có thể tùy chỉnh metric này bằng lệnh "redistribute bgp metric 5". Còn thông số AD 110 (trong [110/20]) là giá trị AD của OSPF, tham khảo thông tin sau:
1710313181728.png


Bước 4: Cấu hình Passive-interface:
Code:
 sbx908-awplus(config)#interface vlan50
 sbx908-awplus(config-if)#ip address 50.0.0.5/8
 
 sbx908-awplus(config)#router ospf 1
 sbx908-awplus(config-router)#passive-interface vlan50
 sbx908-awplus(config-router)#network 50.0.0.0 0.255.255.255 area 0
 sbx908-awplus(config-router)#network 172.16.0.0 0.0.255.255 area 0
 sbx908-awplus(config-router)#network 192.168.1.0 0.0.0.255 area 0
Passive-interface được cấu hình trong trường hợp nếu bạn muốn quảng bá OSPF của interface (như lệnh khai báo network) nhưng không muốn gửi gói OSPF ra khỏi cổng đó vì lý do cổng đó không kết nối với thiết bị OSPF neighbor nào cả (như PC).

Bước 5: Cấu hình quảng bá default route:
Code:
 sbx908-awplus(config)#ip route 0.0.0.0/0 172.16.0.2
sbx908-awplus(config)#router ospf 1
sbx908-awplus(config-router)#network 192.168.1.0 0.0.0.255 area 0
sbx908-awplus(config-router)#default-information originate
Đây là lệnh cho phép thiết bị quảng bá default route 0.0.0.0 của mình vào OSPF cho các thiết bị khác, kiểm tra bảng route thiết bị lân cận ta sẽ thấy thông tin default route dưới dạng "O*E2" và metric là 1:
Code:
 x600-awplus#show ip route
 O*E2    0.0.0.0/0 [110/1] via 192.168.1.2, vlan24, 00:00:29
 C       10.0.0.0/8 is directly connected, vlan1   
 C       20.0.0.0/8 is directly connected, vlan2
 C       30.0.0.0/8 is directly connected, vlan3
 C       192.168.1.0/24 is directly connected, vlan24
 O E2  200.0.0.0/24 [110/1] via 192.168.1.2, vlan24, 00:08:18

Bước 6: Cuối cùng là lệnh kiểm tra thông tin trạng thái OSPF cho thiết bị:
Code:
 SBx908-awplus#show ip ospf database
1710314209940.png


Chúc các bạn thành công :">
 
Last edited:
  • Love
Reactions: huyhuynh

About us

  • Securityzone.vn là một trang web chuyên về an ninh mạng và công nghệ thông tin. Trang web này cung cấp các bài viết, tin tức, video, diễn đàn và các dịch vụ liên quan đến lĩnh vực này. Securityzone.vn là một trong những cộng đồng IT lớn và uy tín tại Việt Nam, thu hút nhiều người quan tâm và tham gia. Securityzone.vn cũng là nơi để các chuyên gia, nhà nghiên cứu, sinh viên và người yêu thích an ninh mạng có thể trao đổi, học hỏi và chia sẻ kiến thức, kinh nghiệm và giải pháp về các vấn đề bảo mật trong thời đại số.

Quick Navigation

User Menu