root
Well-Known Member
- Joined
- Dec 31, 2012
- Messages
- 1,153
- Reaction score
- 71
- Points
- 48
I. Mô hình và yêu cầu
1. Mô hình
2. Yêu cầu
- Cấu hình NAT để các Router bên trong ra internet
- Cấu hình Redistribute sao cho Router và PC bên trong ra được internet
- Sơ đồ IP:
[TABLE="class: grid, width: 800"]
[TR]
[TD]R4[/TD]
[TD]f0/0
f0/1[/TD]
[TD]dhcp
IP: 10.4.4.4/24[/TD]
[/TR]
[TR]
[TD]R3[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.4.4.3/24
IP: 10.3.3.3/24[/TD]
[/TR]
[TR]
[TD]R2[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.3.3.2/24
IP: 10.2.2.2/24[/TD]
[/TR]
[TR]
[TD]R1[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.2.2.1/24
IP: 10.1.1.1/24[/TD]
[/TR]
[TR]
[TD]R5[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.1.1.5/24
IP: 192.168.1.1/24[/TD]
[/TR]
[TR]
[TD]PC[/TD]
[TD][/TD]
[TD]IP: 192.168.1.10/24
Gateway: 192.168.1.1[/TD]
[/TR]
[/TABLE]
II. Triển khai
1. Trên R1
- Cấu hình IP, NAT overload và lan truyền default-route vào bên trong
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R4(config)#int f0/0
R4(config-if)#ip address dhcp
R4(config-if)#no shut
R4(config-if)#int f0/1
R4(config-if)#ip address 10.4.4.4 255.255.255.0
R4(config-if)#no shutdown
R4(config)#access-list 1 permit any
R4(config)#ip nat inside source list 1 interface f0/0 overload
R4(config)#int f0/0
R4(config-if)#ip nat outside
R4(config-if)#int f0/1
R4(config-if)#ip nat inside
R4(config)#router ospf 1
R4(config-router)#network 10.4.4.4 0.0.0.0 area 0
R4(config-router)#default-information originate[/TD]
[/TR]
[/TABLE]
2. Trên R3
- Cấu hình IP, Routing(OSPF và RIP), lan truyền default-route và redistribute để phân phối các lớp mạng trong vùng OSPF và RIP với nhau.
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R3(config)#int f0/0
R3(config-if)#ip address 10.4.4.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#int f0/1
R3(config-if)#ip address 10.3.3.3 255.255.255.0
R3(config-if)#no shutdown
R3(config)#router ospf 1
R3(config-router)#network 10.4.4.3 0.0.0.0 area 0
R3(config-router)#redistribute rip subnets
R3(config)#router rip
R3(config-router)#network 10.3.3.3
R3(config-router)#default-information originate
R3(config-router)#redistribute ospf 1 metric 5[/TD]
[/TR]
[/TABLE]
3. Trên R2
- Cấu hình IP, Routing( RIP và EIGRP), lan truyền default-route và redistribute để phần phối các lớp mạng trong vùng định tuyến EIGRP và RIP với nhau.
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R2(config-if)#int f0/0
R2(config-if)#ip address 10.3.3.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#int f0/1
R2(config-if)#ip address 10.2.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#router rip
R2(config-router)#network 10.3.3.2
R2(config-router)#redistribute eigrp 1 metric 5
R2(config)#router eigrp 1
R2(config-router)#network 10.2.2.2 0.0.0.0
R2(config-router)#redistribute static
R2(config-router)#redistribute rip metric 100000 100 255 1 1500[/TD]
[/TR]
[/TABLE]
4. Trên R1
- Cấu hình IP, Routing: EIGRP và static route và thực hiện redistribute static.
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R1(config)#int f0/0
R1(config-if)#ip address 10.2.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#int f0/1
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#router eigrp 1
R1(config-router)#network 10.2.2.1 0.0.0.0
R1(config-router)#redistribute static metric 100000 100 255 1 1500
R1(config)#ip route 192.168.1.0 255.255.255.0 10.1.1.5[/TD]
[/TR]
[/TABLE]
5. Trên R5
- Cấu hình IP và trỏ default-route về R1
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R5(config)#int f0/0
R5(config-if)#ip address 10.1.1.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#int f0/1
R5(config-if)#ip address 192.168.1.254 255.255.255.0
R5(config-if)#no shutdown
R5(config)#int loopback 0
R5(config-if)#ip address 1.1.1.1 255.255.255.0
R5(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1[/TD]
[/TR]
[/TABLE]
III. Kết quả
- PC ping ra internet thành công
- Show route các Router
- R4
- R3- R2
- R1
- R5
1. Mô hình
- Cấu hình NAT để các Router bên trong ra internet
- Cấu hình Redistribute sao cho Router và PC bên trong ra được internet
- Sơ đồ IP:
[TABLE="class: grid, width: 800"]
[TR]
[TD]R4[/TD]
[TD]f0/0
f0/1[/TD]
[TD]dhcp
IP: 10.4.4.4/24[/TD]
[/TR]
[TR]
[TD]R3[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.4.4.3/24
IP: 10.3.3.3/24[/TD]
[/TR]
[TR]
[TD]R2[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.3.3.2/24
IP: 10.2.2.2/24[/TD]
[/TR]
[TR]
[TD]R1[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.2.2.1/24
IP: 10.1.1.1/24[/TD]
[/TR]
[TR]
[TD]R5[/TD]
[TD]f0/0
f0/1[/TD]
[TD]IP: 10.1.1.5/24
IP: 192.168.1.1/24[/TD]
[/TR]
[TR]
[TD]PC[/TD]
[TD][/TD]
[TD]IP: 192.168.1.10/24
Gateway: 192.168.1.1[/TD]
[/TR]
[/TABLE]
1. Trên R1
- Cấu hình IP, NAT overload và lan truyền default-route vào bên trong
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R4(config)#int f0/0
R4(config-if)#ip address dhcp
R4(config-if)#no shut
R4(config-if)#int f0/1
R4(config-if)#ip address 10.4.4.4 255.255.255.0
R4(config-if)#no shutdown
R4(config)#access-list 1 permit any
R4(config)#ip nat inside source list 1 interface f0/0 overload
R4(config)#int f0/0
R4(config-if)#ip nat outside
R4(config-if)#int f0/1
R4(config-if)#ip nat inside
R4(config)#router ospf 1
R4(config-router)#network 10.4.4.4 0.0.0.0 area 0
R4(config-router)#default-information originate[/TD]
[/TR]
[/TABLE]
- Cấu hình IP, Routing(OSPF và RIP), lan truyền default-route và redistribute để phân phối các lớp mạng trong vùng OSPF và RIP với nhau.
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R3(config)#int f0/0
R3(config-if)#ip address 10.4.4.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#int f0/1
R3(config-if)#ip address 10.3.3.3 255.255.255.0
R3(config-if)#no shutdown
R3(config)#router ospf 1
R3(config-router)#network 10.4.4.3 0.0.0.0 area 0
R3(config-router)#redistribute rip subnets
R3(config)#router rip
R3(config-router)#network 10.3.3.3
R3(config-router)#default-information originate
R3(config-router)#redistribute ospf 1 metric 5[/TD]
[/TR]
[/TABLE]
- Cấu hình IP, Routing( RIP và EIGRP), lan truyền default-route và redistribute để phần phối các lớp mạng trong vùng định tuyến EIGRP và RIP với nhau.
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R2(config-if)#int f0/0
R2(config-if)#ip address 10.3.3.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#int f0/1
R2(config-if)#ip address 10.2.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#router rip
R2(config-router)#network 10.3.3.2
R2(config-router)#redistribute eigrp 1 metric 5
R2(config)#router eigrp 1
R2(config-router)#network 10.2.2.2 0.0.0.0
R2(config-router)#redistribute static
R2(config-router)#redistribute rip metric 100000 100 255 1 1500[/TD]
[/TR]
[/TABLE]
- Cấu hình IP, Routing: EIGRP và static route và thực hiện redistribute static.
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R1(config)#int f0/0
R1(config-if)#ip address 10.2.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#int f0/1
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#router eigrp 1
R1(config-router)#network 10.2.2.1 0.0.0.0
R1(config-router)#redistribute static metric 100000 100 255 1 1500
R1(config)#ip route 192.168.1.0 255.255.255.0 10.1.1.5[/TD]
[/TR]
[/TABLE]
- Cấu hình IP và trỏ default-route về R1
[TABLE="class: outer_border, width: 500"]
[TR]
[TD]R5(config)#int f0/0
R5(config-if)#ip address 10.1.1.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#int f0/1
R5(config-if)#ip address 192.168.1.254 255.255.255.0
R5(config-if)#no shutdown
R5(config)#int loopback 0
R5(config-if)#ip address 1.1.1.1 255.255.255.0
R5(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1[/TD]
[/TR]
[/TABLE]
- PC ping ra internet thành công
- R4
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.1.254 to network 0.0.0.0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 3 subnets
C 10.4.4.0 is directly connected, FastEthernet0/1
O E2 10.3.3.0 [110/20] via 10.4.4.3, 02:52:07, FastEthernet0/1
O E2 10.2.2.0 [110/20] via 10.4.4.3, 02:52:07, FastEthernet0/1
O E2 192.168.1.0/24 [110/20] via 10.4.4.3, 02:20:48, FastEthernet0/1
S* 0.0.0.0/0 [254/0] via 172.16.1.254
- R3
R3#sh ip route
Gateway of last resort is 10.4.4.4 to network 0.0.0.0
10.0.0.0/24 is subnetted, 3 subnets
C 10.4.4.0 is directly connected, FastEthernet0/0
C 10.3.3.0 is directly connected, FastEthernet0/1
R 10.2.2.0 [120/1] via 10.3.3.2, 00:00:07, FastEthernet0/1
R 192.168.1.0/24 [120/5] via 10.3.3.2, 00:00:07, FastEthernet0/1
O*E2 0.0.0.0/0 [110/1] via 10.4.4.4, 03:09:45, FastEthernet0/0
R2#sh ip route
Gateway of last resort is 10.3.3.3 to network 0.0.0.0
10.0.0.0/24 is subnetted, 3 subnets
R 10.4.4.0 [120/1] via 10.3.3.3, 00:00:00, FastEthernet0/0
C 10.3.3.0 is directly connected, FastEthernet0/0
C 10.2.2.0 is directly connected, FastEthernet0/1
D EX 192.168.1.0/24 [170/307200] via 10.2.2.1, 02:22:02, FastEthernet0/1
R* 0.0.0.0/0 [120/5] via 10.3.3.3, 00:00:00, FastEthernet0/0
- R1
R1#sh ip route
Gateway of last resort is 10.2.2.2 to network 0.0.0.0
10.0.0.0/24 is subnetted, 4 subnets
D EX 10.4.4.0 [170/307200] via 10.2.2.2, 02:41:15, FastEthernet0/0
D EX 10.3.3.0 [170/307200] via 10.2.2.2, 02:41:15, FastEthernet0/0
C 10.2.2.0 is directly connected, FastEthernet0/0
C 10.1.1.0 is directly connected, FastEthernet0/1
S 192.168.1.0/24 [1/0] via 10.1.1.5
D*EX 0.0.0.0/0 [170/307200] via 10.2.2.2, 02:41:15, FastEthernet0/0
- R5
R5#sh ip route
Gateway of last resort is 10.1.1.1 to network 0.0.0.0
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/1
S* 0.0.0.0/0 [1/0] via 10.1.1.1