root

Well-Known Member

Cấu hình inter vlan switch layer 3


Với bài lab inter vlan switch layer 3 này, chúng ta sẽ sử dụng một multi layer switch (switch layer 3) để định tuyến cho các VLAN mà các dòng switch layer 2 không làm được. Với dòng switch layer 3 của Cisco ngoài tính năng switch bình thường nó còn có tính năng nâng cao đó là routing giống như Router.
Các bạn có thể tham khảo baif lab trước chúng ta đã cấu hình inter vlan trên Router.

I. Sơ đồ và yêu cầu

1. Sơ đồ lab cấu hình inter vlan switch layer 3


- Đây là mô hình bài lab cấu hình inter vlan switch layer 3. Chúng ta sẽ sử dụng 1 switch layer 3 để định tuyến các VLAN bên trong hệ thống mạng.



2. Yêu cầu:
- Thiết lập sơ đồ
- Thiết lập VTP như sau:

  • DSW là server
  • ASW là client
  • VTP Domain: svuit.com
  • VTP password: 123
- Tạo VLAN cho các DSW như sau:


- Đảm bảo các Switch đồng bộ VLAN với nhau
- Thực hiện định tuyến VLAN trên DSW(default gateway là .254)
- DSW (switch layer 3) làm DHCP Server cấp IP cho từng VLAN
- Thực hiện định tuyến giữa Router và DWS
- Đảm bảo hệ thống đi Internet

- tham khảo thêm các bài lab liên quan.
  1. [Lab 9] Cấu hình inter vlan trên Router Cisco
  2. [Lab 5] Cấu hình Static Route trên Cisco
  3. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
  4. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
  5. [Lab 8] cấu hình giao thức định tuyến EIGRP
- Các bài lý thuyết tham khảo:
  1. [Bài 17] Cấu hình VLAN trunking và VTP Cisco
  2. [Bài 18] Cisco Multilayer Switch Network Diagram
  3. [Bài 11] Tìm hiểu các giao thức định truyến mạng
Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
 
Last edited:

root

Well-Known Member

II. Triển khai inter vlan switch layer 3


1. Switch DSW
- Cấu hình VTP trên DSW (Distributed switch - switch layer 3)
Code:
DSW(config)#vtp mode server
DSW(config)#vtp domain svuit.com
DSW(config)#vtp password 123
- Tạo VLAN và gán port tương ứng cho DSW
Code:
DSW(config)#vlan 2
DSW(config-vlan)#name CCNA
DSW(config-vlan)#vlan 3
DSW(config-vlan)#name CCNP

DSW(config)#interface range
DSW(config)#interface range f0/2-8
DSW(config-if-range)#switchport mode access
DSW(config-if-range)#switchport access vlan 1
DSW(config-if-range)#interface range f0/9-16
DSW(config-if-range)#switchport mode access
DSW(config-if-range)#switchport access vlan 2
DSW(config-if-range)#interface range f0/17-23
DSW(config-if-range)#switchport mode access
DSW(config-if-range)#switchport access vlan 3
Các port đã được gán cho các VLAN


- Tạo đường Trunk giữa DSW và ASW
Code:
DSW(config-if-range)#interface f0/24
DSW(config-if)#switchport trunk encapsulation dot1q
DSW(config-if)#switchport mode trunk
- Thực hiện định tuyến VLAN trên DSW(default gateway .254)
Code:
DSW(config)#interface vlan 1
DSW(config-if)#ip address 172.16.1.254 255.255.255.0
DSW(config-if)#no shutdown
DSW(config-if)#interface vlan 2
DSW(config-if)#ip address 172.16.2.254 255.255.255.0
DSW(config-if)#no shutdown
DSW(config-if)#interface vlan 3
DSW(config-if)#ip address 172.16.3.254 255.255.255.0
DSW(config-if)#no shutdown
DSW(config)#interface f0/1
DSW(config-if)#no switchport
DSW(config-if)#ip address 192.168.1.2 255.255.255.0
- Cấu hình DSW làm DHCP
Code:
DSW(config)#ip dhcp pool VLAN1
DSW(dhcp-config)#network 172.16.1.0 255.255.255.0
DSW(dhcp-config)#default-router 172.16.1.254
DSW(dhcp-config)#dns-server 8.8.8.8
DSW(dhcp-config)#exit
DSW(config)#ip dhcp pool VLAN2
DSW(dhcp-config)#network 172.16.2.0 255.255.255.0
DSW(dhcp-config)#default-router 172.16.2.254
DSW(dhcp-config)#dns-server 8.8.8.8
DSW(dhcp-config)#exit
DSW(config)#ip dhcp pool VLAN3
DSW(dhcp-config)#network 172.16.3.0 255.255.255.0
DSW(dhcp-config)#default-router 172.16.3.254
DSW(dhcp-config)#dns-server 8.8.8.8
- Sử dụng định tuyến RIP giữa Router và DSW để định tuyến
Code:
DSW(config-router)#no auto-summary
DSW(config-router)#network 172.16.1.0
DSW(config-router)#network 172.16.2.0
DSW(config-router)#network 172.16.3.0
DSW(config-router)#network 192.168.1.0
DSW(config-router)#passive-interface vlan 1
DSW(config-router)#passive-interface vlan 2
DSW(config-router)#passive-interface vlan 3
2. Router ISP
- Cấu hình IP và cấp DHCP cho R1
Code:
ISP(config)#interface f0/1
ISP(config-if)#ip address 8.8.8.254 255.0.0.0
ISP(config-if)#no shutdown
ISP(config-if)#interface f0/0
ISP(config-if)#ip address 123.123.123.254 255.255.0.0


ISP(config-if)#ip dhcp pool ISP
ISP(dhcp-config)#network 123.123.0.0 255.255.0.0
ISP(dhcp-config)#default-router 123.123.123.254
ISP(dhcp-config)#dns-server 8.8.8.8
3. Router R1
- Thực hiện đặt IP, xin DHCP, NAT và định tuyến RIP để mạng LAN bên trong ra internet
Code:
R1(config)#interface f0/0
R1(config-if)#ip address dhcp
R1(config-if)#no shutdown
R1(config-if)#interface f0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#access-list 1 permit any
R1(config)#ip nat inside source list 1 interface f0/0 overload
R1(config)#interface f0/0
R1(config-if)#ip nat outside
R1(config-if)#interface f0/1
R1(config-if)#ip nat inside

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.1.0
R1(config-router)#default-information originate
Bảng đinh tuyến trên R1 đã xuất hiện các VLAN


- Bảng định tuyến trên Switch DSW




3. Switch ASW

- Thiết lập VTP client và chuyển mode Trunk trên interface f0/24
Code:
ASW(config)#vtp mode client
ASW(config)#vtp domain svuit.com
ASW(config)#vtp password 123

ASW(config-if-range)#interface f0/24
ASW(config-if)#switchport mode trunk
- Gán port cho VLAN được đồng bộ từ server
Code:
ASW(config)#interface range f0/1-8
ASW(config-if-range)#switchport mode access
ASW(config-if-range)#switchport access vlan 1
ASW(config-if-range)#interface range f0/9-16
ASW(config-if-range)#switchport mode access
ASW(config-if-range)#switchport access vlan 2
ASW(config-if-range)#interface range f0/17-23
ASW(config-if-range)#switchport mode access
ASW(config-if-range)#switchport access vlan 3
- Như vậy là trên ASW sẽ có các VLAN được đồng bộ từ server và các port tưng ứng cho các VLAN





4. Trên các PC
- Ta cắm các PC vào các port của VLAN 1,2,3 để kiểm tra
- Xin DHCP trên PC 1 cắm vào port f0/1 của ASW


- trên pc 2 cắm vào port f0/10 của ASW ta thực hiện ping ra internet và ping các VLAN khác



 
Last edited:

tranvankuong

New Member
Bác root ơi cho e hỏi bác dùng phần mềm gì để giả lập lab vậy?
E xài gns3 & iou đều k đc.
Thanks bác!
 

tranvoluong

New Member
root ơi, trên bài này nếu đặt DHCP tại router có được không? Dùng DHCP relay agent? Nếu như vậy thì phải làm giống mô hình này à? http://clubitnghean.blogspot.com/2011/12/cau-hinh-routing-tren-switch-layer-3.html.

Ở bài này em thấy trên con DSW chẳng có kết nối gì hết vậy gắn port access làm gì ạ? Nếu root không add bất kỳ một port nào vào VLAN cả, vậy khi định tuyển trên con router có thấy được route đó không (vd: vlan1) chẳng hạn
 
Last edited:
Top