CCNA VLAN Rounting - Router on a stick

HanaLink

Junior – IT Sơ cấp
Mar 11, 2022
129
15
18
25
Ho Chi Minh City
1657872220222.png

Yêu cầu: Cấu hình định tuyến sao cho các PC có thể giao tiếp được với nhau (Switch layer 2)

1. Đặt địa chỉ IP cho PC

VPC5: 192.168.1.1/24
VPC6: 192.168.2.1/24
VPC7: 192.168.3.1/24
VPC8: 192.168.4.1/24

2. Cấu hình Mode Access và Trunk VLAN tại Switch
Trên Switch 3:
Code:
SW3(config)#vlan 10,20,30,40
SW3(config-vlan)#exit

SW3(config)#interface GigabitEthernet0/1
SW3(config-if)#switchport mode access
SW3(config-if)#switchport access vlan 10
SW3(config-if)#exit
SW3(config)#interface GigabitEthernet0/2
SW3(config-if)#switchport mode access
SW3(config-if)#switchport access vlan 20
SW3(config-if)#exit
SW3(config)#interface GigabitEthernet0/0
SW3(config-if)#switchport trunk allowed vlan 10,20,30,40
SW3(config-if)#switchport trunk encapsulation dot1q
SW3(config-if)#switchport mode trunk
SW3(config-if)#exit

Trên Switch 4:
Code:
SW4(config)#vlan 10,20,30,40
SW4(config-vlan)#exit

SW4(config)#interface GigabitEthernet0/1
SW4(config-if)#switchport mode access
SW4(config-if)#switchport access vlan 30
SW4(config-if)#exit
SW4(config)#interface GigabitEthernet0/2
SW4(config-if)#switchport mode access
SW4(config-if)#switchport access vlan 40
SW4(config-if)#exit
SW4(config)#interface GigabitEthernet0/0
SW4(config-if)#switchport trunk allowed vlan 10,20,30,40
SW4(config-if)#switchport trunk encapsulation dot1q
SW4(config-if)#switchport mode trunk
SW4(config-if)#exit

3. Cấu hình Subinterface tại Router
Trên Router 1:
Code:
R1(config)#interface G0/0
R1(config-if)#ip address 192.168.5.2 255.255.255.0
R1(config-if)#exit
R1(config)#interface G0/0.10
R1(config-if)#encapsulation dot1Q 10
R1(config-if)#ip address 192.168.1.2 255.255.255.0
R1(config-if)#exit
R1(config-if)#interface G0/0.20
R1(config-if)#encapsulation dot1Q 20
R1(config-if)#ip address 192.168.2.2 255.255.255.0

Trên Router 2:
Code:
R2(config)#interface G0/1
R2(config-if)#ip address 192.168.6.2 255.255.255.0
R2(config-if)#exit
R2(config)#interface G0/1.30
R2(config-if)#encapsulation dot1Q 30
R2(config-if)#ip address 192.168.3.2 255.255.255.0
R2(config-if)#exit
R2(config-if)#interface G0/1.40
R2(config-if)#encapsulation dot1Q 40
R2(config-if)#ip address 192.168.4.2 255.255.255.0

4. Cấu hình Static Route và Gateway cho PC
Trên Router 1:
Code:
R1(config)#ip route 192.168.3.0 255.255.255.0 G0/1
R1(config)#ip route 192.168.4.0 255.255.255.0 G0/1

Trên Router 2:
Code:
R2(config)#ip route 192.168.1.0 255.255.255.0 G0/0
R2(config)#ip route 192.168.2.0 255.255.255.0 G0/0

Trên các PC thì Gateway về IP Subinterface tương ứng với từng VLAN:
VPC5: 192.168.1.1/24 - Gateway: 192.168.1.2
VPC6: 192.168.2.1/24 - Gateway: 192.168.2.2
VPC7: 192.168.3.1/24 - Gateway: 192.168.3.2
VPC8: 192.168.4.1/24 - Gateway: 192.168.4.2

5. Kiểm tra
1657872640774.png

Kiểm tra với các PC tương tự sẽ thấy được kết quả.

Chúc các bạn thành công :">
 

Attachments

  • 1657870267771.png
    1657870267771.png
    149.5 KB · Views: 0
  • 1657872463321.png
    1657872463321.png
    14.4 KB · Views: 0
Last edited:

About us

  • Securityzone.vn là một trang web chuyên về an ninh mạng và công nghệ thông tin. Trang web này cung cấp các bài viết, tin tức, video, diễn đàn và các dịch vụ liên quan đến lĩnh vực này. Securityzone.vn là một trong những cộng đồng IT lớn và uy tín tại Việt Nam, thu hút nhiều người quan tâm và tham gia. Securityzone.vn cũng là nơi để các chuyên gia, nhà nghiên cứu, sinh viên và người yêu thích an ninh mạng có thể trao đổi, học hỏi và chia sẻ kiến thức, kinh nghiệm và giải pháp về các vấn đề bảo mật trong thời đại số.

Quick Navigation

User Menu