Lab 1 : Additional Domain - Active Directory part 3

root

Well-Known Member
Additional Domain
[HR][/HR]
I. Mô hình


II. Cấu hình IP
Primary ADAdditional DC
IP192.168.10.11192.168.10.12
Gateway192.168.10.1192.168.10.1
Primary DNS192.168.10.11192.168.10.11
Secondary192.168.10.12192.168.10.12

  • Lưu ý : để cài addtional DC cần chú ý 2 máy server phải khác SSID

III. Triển khai

1. Trên máy Primary :
  • Cho phép máy Additional transfer các zone DNS : svuit.local


- Cho phép các Zones từ Primary transfer đến Secondary (các bạn điền IP của Secondary vào nhé)


2. Trên máy Additional

  • Cấu hình IP
  • Cài đặt DNS(các bước cài đặt các bạn xem lại part 1 nhé). Nhưng có một điểm khác là lần này chúng ta sẽ chọn Secondary zone để lấy zone svuit.local từ Primary DNS






  • Sau khi cài xong DNS cho Additional thì ta tiến hành transfer các zone từ primary DNS về cho Secondary DNS. Các bạn lên máy Primary và thực hiện transfer như hình dưới đây nhé




  • Các bạn lên máy Secondary và Refesh để thấy kết quả của Secondary DNS đã được cập nhập từ máy chủ Primary DNS


3. Nâng cấp server lên Additional Domain

  • Vào Server Manage để add role Active Directory




  • Ở đây ta chọn add 1 domain vào 1 hệ thống Domain có sẵn là svuit.local với user/pass là của máy Primary DC




  • Và ta install và chờ kết thúc quá trình và server sẽ tự khởi động lại


IV. Kết quả


  • Sau khi cài đặt thành công chúng ta có thể vào Active Directory để kiểm tra xem là đã thấy 2 server chưa




  • Khi chúng ta qua máy Primary DC tạo 1 user mới thì máy chủ Additional sẽ tự động cập nhập user này qua bên nó.
    [*=1]Trên Primary DC các bạn thực hiện tạo 1 user nhé




  • [*=1]Các bạn quá máy Additional DC refesh để xem kết quả. Nó sẽ cập nhập user từ Primarry sang Addition nhé

 
Chào bạn Root, bạn có thể giúp post lại hình bài này, vì mình gặp phải tình trường hợp chỉ cài một DNS nội bộ đặt tại hội sở chính sử dụng chung cho tất cả các chi nhánh, nên khi các chi nhánh mất kết nối về hội sở chính thí các máy trạm tại chi nhánh không thể vào internet được, dù mỗi chi nhánh đều có đường internet riêng, như mô hình sau:

2014-12-20_063102.png

Cám ơn bạn Root rất nhiều.
 

root

Well-Known Member
hi anh,

Em đang kiếm lại hình và sẽ upload sau nhé.

với mô hình trên cho em hỏi vài vấn đề sau
1. Client ở chi nhánh được cấp DNS là do thiết bị nào cấp ?
2. Client ở chi nhánh được cấp DNS có IP là gi ?
3. Khi chi nhánh mất kết nối về Hội sở. theo mô tả ở trên thì client ở chi nhánh không thể ra internet (ở đây là lướt web không được đúng ko ?) vầy client có ping được ra internet không ? (khúc này cần đảm bảo rằng hệ thống mạng của chi nhánh ko chặn gói icmp nhé!)
4. DNS ở hội sở có ra được internet không ? Mục đích của DNS server ở sở có tác dụng như thế nào ...?

Thanks,
 

root

Well-Known Member
Em sẽ làm 1 bài lab giả lập để mô phỏng mô hình tạm thời của cty anh nhé!

1. Mô hình



2. Cấu hình
- Trên Router chi nhánh: Router R1

//port này sẽ kết nối tới internet của chi nhánh
R1(config)#int f1/0
R1(config-if)#ip nat outside
R1(config-if)#ip add dhcp
R1(config-if)#no shut

//port này sẽ kết nối tới mạng LAN của chi nhánh
R1(config-if)#int f0/1
R1(config-if)#ip nat inside
R1(config-if)#ip add 192.168.10.254 255.255.255.0
R1(config-if)#no shut

//port này sẽ kết nối tới hội sở
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#ip nat inside
R1(config-if)#no shut

//thực hiện NAT overload để client trong LAN chi nhánh ra internet
R1(config)#access-list 1 permit any
R1(config)#ip nat inside source list 1 interface f1/0

// Route tới lớp mạng LAN chứa DNS server của hội sở
R1(config)#ip route 192.168.20.0 255.255.255.0 10.10.10.2

- Tiếp theo là Router chi nhánh sẽ thực hiện cấp DHCP. Việc cấp DHCP của Router chi nhánh phải đảm bảo rằng client sẽ nhận được 2 IP DNS:
  • 1 IP DNS của DNS server tại hội sở
  • 1 DNS public để client có thể phân giải các tên miền ngoài internet. Giúp client truy cập internet khi client mất kết nối với DNS server hội sở
R1(config)#ip dhcp pool LAN
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.20.254

// Ở đây mình sẽ ưu tiên cho DNS nội bộ (DNS server của hội sở) sau đó tới DNS public ngoài internet
R1(dhcp-config)#dns-server 192.168.20.20 8.8.8.8 8.8.4.4

- THử dùng PC trong LAN của chi nhánh kết nối vào mạng của chi nhánh. Xem Client ở chi nhánh có nhân được IP, Gateway, DNS đúng như mình đã cấu hình ở trên không



- Cấu hình trên Router 2 - Router hội sở

R2(config)#int f0/0
R2(config-if)#no ip address dhcp
R2(config-if)#ip add 10.10.10.2 255.255.255.0
R2(config-if)#no shut

R2(config-if)#int f0/1
R2(config-if)#ip add 192.168.20.254 255.255.255.0
R2(config-if)#no shut

R2(config)#int f1/0
R2(config-if)#ip add dhcp
R2(config-if)#no shut

// Route tới mạng LAN của chi nhánh
R2(config)#ip route 192.168.10.0 255.255.255.0 10.10.10.1

- Cấu hình DNS server của hội sở để client chi nhánh có thể truy cập website svuit.org đặt tại WEB server nằm trong LAN hội sở. Kiểm tra các zones phân giải nghich và thuận đảm bảo phân giải thành công các tên miền




- Bây giờ mình sẽ lấy client chi nhánh truy cập các website ngoài internet và website nội bộ xem có thành công không


- Giờ mình sẽ ngắt đường kết nối giữa chi nhánh và hội sở nhé. Lúc này client ở chi nhánh sẽ không truy cập được website nội bộ nữa. Nhưng vấn có thể truy cập các website ngoài internet
- Lên Router R2 ở hội sở shutdown port f0/0
- Router R1 tại chi nhánh đã mất kết nối với hội sở. Như vậy client trong chi nhánh cũng không thể nào truy cập tới DNS, website bên hội sở được nữa

R1(dhcp-config)#do ping 192.168.20.20


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.20, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

R2(config)#int f0/0
R2(config-if)#shutdown


 
Top